В системе счисления с основанием p выполняется равенство:
zxyx5 + xy816 = wzx70
Буквами x, y, z и w обозначены некоторые цифры из алфавита системы счисления с основанием p. Определите значение числа xyzwp и запишите это значение в десятичной системе счисления.

Посмотреть решение

alf = '0123456789abcdefghijklmnopqrstuvwxyz'
for p in range(10,37):
    for x in alf[:p]:
        for y in alf[:p]:
            for z in alf[:p]:
                for w in alf[:p]:
                    if int(f'{z}{x}{y}{x}5',p) + int(f'{x}{y}816',p)==int(f'{w}{z}{x}70',p):
                        print(int(f'{x}{y}{z}{w}',p))

Ответ:7665