Исполнитель преобразует число на экране.
У исполнителя есть три команды, которые обозначены латинскими буквами:
A. Вычесть 1
B. Вычесть 3
C. Найти целую часть от деления на 2
Программа для исполнителя — это последовательность команд. Сколько существует программ, для которых при исходном числе 19 результатом является число 3, при этом траектория вычислений не содержит числа 9 и содержит 12?

Посмотреть решение

def f(b,e):
    if b<e or b==9: return 0
    if b==e: return 1
    return f(b-1,e)+f(b-3,e)+f(b//2,e)
print(f(19,12)*f(12,3))

Ответ:153