Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, для чисел которых выполнены оба условия:
– наибольшее число строки меньше суммы трёх других;
– четыре числа нельзя разбирать на две пары с равными суммами.
В ответе запишите только число

Посмотреть решение

count=0
for a in open("9.txt"):    
    s=[int(x) for x in a.split()]
    if ((sum(s)-max(s))>max(s)) and ((s[0]+s[1]!=s[2]+s[3]) and (s[0]+s[2]!=s[1]+s[3]) and (s[0]+s[3]!=s[2]+s[1])):
        count+=1
print(count)

Ответ:251