15_задание_ЕГЭ

Определите натуральное число A из интервала [75, 125] такое, что выражение
((x & 56 ≠ 0) ∨ (x & 43 ≠ 0)) → (x & A ≠ 0)
тождественно истинно (то есть принимает значение 1 при любом натуральном значении переменной x?

Посмотреть решение

def f(x,A):
    return (((x&56!=0) or (x&43!=0)) <= (x & A !=0))
for A in range(75,126):
    if all(f(x,A) for x in range(100)):
        print(A)
        break

Ответ:123

Сколько существует целых значений А, при которых формула(((x–10)⋅(x+1) ≤ 0) ∧ (x⋅x > A)) ∨ ((y⋅y ≤ A) ∧ ((y–10)⋅(y+1) > 0)) тождественно ложна (то есть принимает значение 0 при любых целых неотрицательных значениях переменных x и y)?

Посмотреть решение

def f(x,y,A):
    return ((((x-10)*(x+1)<=0) and (x*x)>A) or ((y*y<=A) and ((y-10)*(y+1)>0)))
count=0
for A in range(300):
    if all(f(x,y,A)==0 for x in range(300) for y in range(300)):
        count+=1
print(count)

Ответ:21