Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа A формула ДЕЛ(70, A) /\ (ДЕЛ(x, 28) → (¬ДЕЛ(x, A) → ¬ДЕЛ(x, 21))) тождественно истинна, то есть принимает значение 1 при любом натуральном x?

Показать решение

print('informatikstr.ru')
for A in range(1,100):
    stop=0
    for x in range(1,1000):
        if ((70%A==0) and ((x%28==0)<=((not(x%A==0))<=(not(x%21==0))))) == 0:
            stop=1
            break
    if stop==0:
        print(A)

Ответ: 14


Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа А формула(¬ДЕЛ(x, А ) /\ ДЕЛ(x, 6)) → ¬ДЕЛ(x, 3) тождественно истинна (то есть принимает значение 1 при любом натуральном значении переменной х)?

Показать решение

print('informatikstr.ru')
for A in range(1,100):
    stop=0
    for x in range(1,1000):
        if (((x % A !=0) and (x % 6 ==0)) <= (x % 3 !=0)) == 0:
            stop=1
            break
    if stop==0:
        print(A)

Ответ: 6


Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа A формула ДЕЛ(70, A) /\ (¬ДЕЛ(x, A) → (ДЕЛ(x, 35) → ¬ДЕЛ(x, 63))) тождественно истинна, то есть принимает значение 1 при любом натуральном х?

Показать решение

print('informatikstr.ru')
for A in range(1,100):
    stop=0
    for x in range(1,1000):
        if ((70 % A == 0) and ((x % A !=0) <= ((x % 35 ==0) <= (x % 63 ==0))))== 0:
            stop=1
            break
    if stop==0:
        print(A)

Ответ: 35


Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наименьшего натурального числа A формула (¬ДЕЛ(х, 84) ∨ ¬ДЕЛ(х, 90)) → ¬ДЕЛ(х, А)
тождественно истинна, то есть принимает значение 1 при любом натуральном х?

Показать решение

print('informatikstr.ru')
for A in range(1,10000):
    stop=0
    for x in range(1,10000000):
        if ((x % 84 !=0 or x % 90 !=0) <= (x % A !=0))== 0:
            stop=1
            break
    if stop==0:
        print(A)
        break

Ответ: 1260


Для какого наименьшего целого неотрицательного числа А выражение (75 ≠ 2x + 3y) ∨ (A > 3x) ∨ (A > 2y) тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x, y?

Показать решение

print('informatikstr.ru')
for A in range(1,100):
    stop=0
    for x in range(1,1000):
        for y in range(1,1000):
            if ((75 != 2*x + 3*y) or (A>3*x) or (A>2*y))== 0:
                stop=1
                break
    if stop==0:
        print(A)
        break

Ответ: 35


Для какого наименьшего целого неотрицательного числа А выражение (x – 2y < 3A) ∨ (2y > x) ∨ (3x > 50) тождественно истинно, т.е. принимает значение 1 при любых целых положительных x и y?

Показать решение

print('informatikstr.ru')
for A in range(1,100):
    stop=0
    for x in range(1,1000):
        for y in range(1,1000):
            if ((x - 2 * y < 3 * A) or (2 * y > x) or (3 * x > 50))== 0:
                stop=1
                break
    if stop==0:
        print(A)
        break

Ответ: 5


Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наименьшего натурального числа A формула (ДЕЛ(x, A – 21) /\ ДЕЛ(x, 40 – A)) → ДЕЛ(x, 90) тождественно истинна, то есть принимает значение 1 при любом натуральном х?

Показать решение

print('informatikstr.ru')
for A in range(22,100):
    stop=0
    for x in range(1,1000):
        for y in range(1,1000):
            if (((x % (A - 21) == 0) and (x % (40 - A) == 0)) <= (x % 90 == 0))== 0:
                stop=1
                break
    if stop==0:
        print(A)
        break

Ответ: 30


Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наименьшего натурального числа А формула (ДЕЛ(x, A) ∧ ДЕЛ(x, 21)) → ДЕЛ(x, 18) тождественно истинна (то есть принимает значение 1 при любом натуральном значении переменной х)?

Показать решение

print('informatikstr.ru')
for A in range(1,100):
    stop=0
    for x in range(1,1000):
        if ((x % A == 0 and x % 21 == 0) <= (x % 18 ==0)) == 0:
            stop=1
            break
    if stop==0:
        print(A)
        break

Ответ: 18


Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наименьшего натурального числа A формула ДЕЛ(A, 45) /\ (ДЕЛ(750, x) → (¬ДЕЛ(A, x) → ¬ДЕЛ(120, x))) тождественно истинна, то есть принимает значение 1 при любом натуральном x?

Показать решение

print('informatikstr.ru')
for A in range(1,200):
    stop = 0
    for x in range(1,10000):        
        if ((A % 45 == 0) and ((750 % x == 0) <= ((A % x != 0) <= (120 % x !=0)))) == 0:
            stop = 1
            break
    if stop == 0:
        print(A)
        break

Ответ: 90


Укажите наименьшее целое значение А, при котором выражение (6х + 4у != 34) ∨ (А > 5х + 3у) ∧ (А > 4у + 15х — 35) истинно для любых целых положительных значений х и у.

Показать решение

print('informatikstr.ru')
for A in range(1,100):
    stop = 0
    for x in range(1,100):
        for y in range(1,100):
            if ((6*x + 4*y != 34) or (A > 5*x + 3*y) and (A > 4*y + 15*x - 35))== 0:
                stop = 1
                break
    if stop == 0:
        print(A)
        break

Ответ: 45


На числовой прямой даны два отрезка: D = [17, 58] и C = [29, 80]. Укажите наибольшую возможную длину промежутка A, для которого формула (x ∈ D) → ((¬(x ∈ C) ∧ ¬(x ∈ A)) → ¬(x ∈ D) тождественно истинна, то есть принимает значение 1 при любом значении переменной х.

Показать решение

d = {i for i in range(17,59)}
c = {i for i in range(29,81)}
a = set()
for x in range(1,100):
    if ((x in d) <= (((x not in c) and (x not in a)) <= (x not in d))) == 0:
        a.add(x)
print(len(a))

Ответ: 12


Обозначим через m & n поразрядную конъюнкцию неотрицательных целых чисел n и m. Так, например, 14 & 5 = 11102 & 01012 = 01002 = 4. Для какого наибольшего целого положительного числа А выражение (x&A=0)∨¬(x&37=0)∨¬(x&12=0)тождественно истинно, то есть принимает значение при любых целых положительных х?

Показать решение

for A in range(10,2000):
    stop = 0
    for x in range(10,2000):
        if ((x&A == 0) or (not(x&37 == 0)) or (not(x&12 == 0))) == 0:
            stop = 1
    if stop == 0:
        print(A)

Ответ: 45