Рассматривается множество целых чисел, принадлежащих отрезку [1012; 9638], которые делятся на 3 и не делятся на 11, 13, 17 и 19. Найдите количество таких чисел и максимальное из них. В ответе запишите два числа через пробел: сначала количество, затем максимальное число.

Показать решение

print('informatikstr.ru')
count=0
max=0
for i in range(1012,9638+1):
    if i%3==0 and i%11!=0 and i%13!=0 and i%17!=0 and i%19!=0:
        count+=1
        max=i
print(count,max)

Ответ: 2151 9630


Рассматривается множество целых чисел, принадлежащих отрезку [3201;12876], которые делятся на 4 и не делятся на 7, 11, 13 и 19. Найдите количество таких чисел и максимальное из них. В ответе запишите два числа через пробел: сначала количество, затем максимальное число.

Показать решение

print('informatikstr.ru')
count=0
max=0
for i in range(3201,12876+1):
    if i%4==0 and i%7!=0 and i%11!=0 and i%13!=0 and i%19!=0:
        count+=1
        max=i
print(count,max)

Ответ: 1649 12876


Рассматривается множество целых чисел, принадлежащих отрезку [1100;11000], которые делятся на 6 и не делятся на 7, 13, 17 и 23. Найдите количество таких чисел и максимальное из них. В ответе запишите два числа через пробел: сначала количество, затем максимальное число.

Показать решение

print('informatikstr.ru')
count=0
max=0
for i in range(1100,11000+1):
 if i%6==0 and i%7!=0 and i%13!=0 and i%17!=0 and i%23!=0:
  count+=1
  max=i
print(count,max)

Ответ: 1178 10992


Рассматривается множество целых чисел, принадлежащих отрезку [1512;13202], которые делятся на 7 и не делятся на 11, 13, 17 и 23. Найдите количество таких чисел и максимальное из них. В ответе запишите два числа через пробел: сначала количество, затем максимальное число.

Показать решение

print('informatikstr.ru')
count=0
max=0
for i in range(1512,13202+1):
    if i%7==0 and i%11!=0 and i%13!=0 and i%17!=0 and i%23!=0:
        count+=1
        max=i
print(count,max)

Ответ: 1265 13188


Рассматривается множество целых чисел, принадлежащих числовому отрезку [331; 8751], которые удовлетворяют следующим условиям:
− количество цифр в десятичной и шестнадцатеричной записях одинаковое;
− кратны 5, но не 25.
Найдите количество таких чисел и максимальное из них.

Показать решение

print('informatikstr.ru')
count=0
max=0
for i in range(331,8751+1):
    b=len(str(i))
    c=len(hex(i)[2:])
    if b==c and i%5==0 and i%25!=0:
        count+=1
        max=i
print(count, max)

Ответ: 851 8745


Назовём натуральное число подходящим, если у него больше 17 различных делителей (включая единицу и само число). Определите количество подходящих чисел, принадлежащих отрезку [10 001; 50 000], а также наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число.

Показать решение

print('informatikstr.ru')
def F(n):
    delitel=2
    countdel=2
    while delitel ** 2 < n:
        if n % delitel == 0:
            countdel += 2 
            if countdel > 17:
                return 1
        delitel += 1
count=0
min=50001
for i in range(10001,50000+1):
    if F(i)==1:
        count += 1
        if i < min:
            min = i
print(count, min)

Ответ: 6585 10008


Рассматривается множество целых чисел, принадлежащих числовому отрезку [10; 10000], которые удовлетворяют следующим условиям:
− содержат в двоичной системе счисления 5 нулей и заканчиваются единицей;
− кратны 3 и 11.
Найдите количество таких чисел и минимальное из них.

Показать решение

print('informatikstr.ru')
max=0
count=0
for i in range(10,10000):
    a = bin(i)[2:]
    if i % 3 == 0 and i % 11 != 0 and a.count('0') == 5 and a[-1] == '1':
        if i>max:
            max=i
        count+=1
print(count,max)

Ответ: 251 9963


Назовём натуральное число подходящим, если у него ровно 3 различных простых делителя. Например, число 180 подходящее (его простые делители – 2, 3 и 5), а число 12 – нет (у него только два различных простых делителя). Определите
количество подходящих чисел, принадлежащих [10 001; 50 000], а также наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число.

Показать решение

print('informatikstr.ru')
def F(n):
    delitel=2
    while delitel ** 2 <= n:
        if n % delitel == 0:
                return False
        delitel += 1
    return True
def G(n):
    count = 0
    delitel=2
    while delitel ** 2 <= n:
        if n % delitel == 0:
            if F(delitel):
                count +=1
            if F(n // delitel):
                count +=1 
            if count > 3:
                break
        delitel += 1
    if delitel ** 2 == n:
        count +=1
    return count
                
kol=0
min=50001
for i in range(10001,50000+1):
    if G(i) == 3:
        kol += 1
        if i < min:
            min = i
print(kol, min)

Ответ: 15652 10002


Рассматривается множество целых чисел, принадлежащих числовому отрезку [3912; 9193], которые удовлетворяют следующим условиям: − сумма цифр числа кратна 9;− шестнадцатеричная запись числа не заканчивается на 21.Найдите количество таких чисел и максимальное из них.

Показать решение

print('informatikstr.ru')
maxi = 0
count = 0
for i in range(3912, 9194):
    sum = i // 1000 + i % 10 + i % 100 // 10 + i % 1000 // 100
    if sum % 9 == 0:
        if i % 256 != 33:
                count += 1
                if i > maxi:
                    maxi = i
print(count, maxi)

Ответ: 585 9189


Файл содержит последовательность неотрицательных целых чисел, не превышающих 10 000. Назовём парой два идущих подряд элемента последовательности. Определите количество пар, в которых хотя бы один из двух элементов делится на 3 и хотя бы один из двух элементов меньше среднего арифметического всех чётных элементов последовательности. В ответе запишите два числа: сначала количество найденных пар, а затем – максимальную сумму элементов таких пар.
Например, в последовательности (3 8 9 4) есть две подходящие пары: (3 8) и (9 4), в ответе для этой последовательности надо записать числа 2 и 13.

Показать решение

print('informatikstr.ru')
spisok = []
with open('17.txt') as f:
    for n in f:
        spisok.append(int(n))
kol = 0
summ = 0
for i in range(len(spisok)):
    if spisok[i] % 2 == 0:
        kol += 1
        summ += spisok[i]
sred = summ // kol
count = 0
maxi = 0
for i in range(len(spisok) - 1):
    if (spisok[i] % 3 == 0 or spisok[i + 1] % 3 == 0) and (spisok[i] < sred or spisok[i + 1] < sred):
        count += 1
        maxi = max(maxi, spisok[i] + spisok[i + 1])
print(count, maxi)

Ответ:2288 14875